GetBlock - Account/Website – Incident details

Account/Website

Resolved
Major outage
Started about 1 month agoLasted 8 minutes

Affected

Site & Account

Major outage from 2:29 PM to 2:37 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating
    New services being implemented and payment issues might happen for about 10-15 minutes please wait for the stated time and let us know if you run into any issues