GetBlock - LTC Mainnet – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Discord
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
All systems operational
LTC Mainnet
Resolved
Major outage
Started 25 days ago
Lasted 14 minutes
Affected
Litecoin (LTC)
Major outage from 12:52 AM to 1:06 AM
Mainnet
Major outage from 12:52 AM to 1:06 AM
Testnet
Major outage from 12:52 AM to 1:06 AM
Updates
Resolved
March 22, 2026 at 1:06 AM
Resolved
March 22, 2026 at 1:06 AM
This incident has been resolved.
Identified
March 22, 2026 at 12:52 AM
Identified
March 22, 2026 at 12:52 AM
We are continuing to work on a fix for this incident.